Excel 2007 : Comment utiliser INDEX, EQUIV, SOMME, numéro de semaine, SOMME PROD, Grande.valeur sur Excel en moins de 5 min.

EXCEL_2007_EX_INDEX_EQUIV_ Num_SEMAINE_SOMME_DECALER Excel 2007 : Comment utiliser INDEX, EQUIV, SOMME, numéro de semaine, SOMME PROD, Grande.valeur sur Excel en moins de 5 min.

EXCEL_2007_EX_INDEX_EQUIV_ Num_SEMAINE_SOMME_DECALER

Excel 2007 : Comment utiliser INDEX, EQUIV, SOMME, numéro de semaine, SOMME PROD, Grande.valeur sur Excel en moins de 5 min.

 

 

Problématique :

J’ai besoin de renvoyer le numéro de semaine par rapport à une date; de calculer le n valeur les plus grande d’une plage.

J’ai besoin d’afficher en fonction du numéro de semaine/ OF( ordre de fabrication)/OP ( Ordre de Production/ Responsable de garde ou de permanence etc…

 

Version Youtube :

 

Utilisation tableau, formule Index/equiv; validation de donnée.

EXCEL_2007_EX_INDEX_EQUIV_ Num_SEMAINE_SOMME_DECALER Excel 2007 : Comment utiliser INDEX, EQUIV, SOMME, numéro de semaine, SOMME PROD, Grande.valeur sur Excel en moins de 5 min.

EXCEL_2007_EX_INDEX_EQUIV_ Num_SEMAINE_SOMME_DECALER

Utilisation de la formule pour convertir une date en N°semaine :

=SI(ESTVIDE(A8); »NC »;ENT(MOD(ENT((A8-2)/7)+0,6;52+5/28))+1)

EXCEL_2007_EX_INDEX_EQUIV_ Num_SEMAINE_SOMME_DECALER Excel 2007 : Comment utiliser INDEX, EQUIV, SOMME, numéro de semaine, SOMME PROD, Grande.valeur sur Excel en moins de 5 min.

EXCEL_2007_EX_INDEX_EQUIV_ Num_SEMAINE_SOMME_DECALER

Utilisation de la formule permettant de renvoyer l’OF à produire pour la semaine en question :

EXCEL_2007_EX_INDEX_EQUIV_ Num_SEMAINE_SOMME_DECALER Excel 2007 : Comment utiliser INDEX, EQUIV, SOMME, numéro de semaine, SOMME PROD, Grande.valeur sur Excel en moins de 5 min.

EXCEL_2007_EX_INDEX_EQUIV_ Num_SEMAINE_SOMME_DECALER

=SIERREUR(INDEX(Tableau1[Lot à industrialiser];EQUIV($G$7;Tableau1[SEMAINE];0)); »Pas de lot industriel (OF) à produire »)

Utilisation de la formule GRANDE.VALEUR permettant de renvoyer les n quantitéles plus grande et ensuite les sommer :

Utilisation de la formule GRANDE.VALEUR pour additionner les n qté les plus importantes

=SOMMEPROD(GRANDE.VALEUR(Tableau1[qté à produire];{1;2;3;4}))

 

Utilisation de la fonction decaler pour ensuite additionner une plage :

=SOMME(DECALER(D$7;1;0;LIGNES($D$7:$D$15)-2))

L’idée est d’utiliser la formule suivante : =SOMME(DECALER(B$1;1;0;LIGNES($B$1:$B$5)-2))
pour permettre l’ajout de lignes en dessous et au dessus de la plage.
Dans le détail :

1/ Si on décompose la formule, on part de la plage qui contient le titre du haut (D7) et la cellule du résultat (D15) et on calcule le nombre de lignes : LIGNES($D$7:$D$15).
2/ On enlève deux lignes LIGNES($D$7:$D$15)-2 pour la ligne de titre et la ligne contenant la formule SOMME
3/ On va ensuite utiliser la formule DECALER pour retourner la plage sur laquelle faire la somme : DECALER(D$7;1;0;LIGNES($D$7:$D$15)-2).
Cette formule se lit : définit une plage partant de D$7, décale cette cellule de 1 ligne vers le bas, de 0 colonne vers la droite, et définit la hauteur de la plage comme étant LIGNES($D$7:$D$15)-2. Cela renvoit donc la plage D18:D14.
4/ Il ne reste plus qu’à faire la SOMME.

Recevoir la newsletter

Inscrivez-vous maintenant et recevez un e-mail les fois où je publie du contenu.

I agree to have my personal information transfered to AWeber ( more information )

Je hais les spams. Vous pouvez vous désinscrire à tout moment.

Pour marque-pages : Permaliens.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *