EXCEL_2007_ANALYSE_ECART_ONGLET

EXCEL_2007_ANALYSE_ECART_ONGLET

Comment comparer une plage de donnée sur Excel d’un onglet à l’autre en moins de 5 min.

 

J’ai toujours souhaité comparer des écarts notamment par rapport à mon activité pro, sur des livrables avec structure de document similaire et passage d’indice d’une version à l’autre…Voilà une piste de comment faire..[sociallocker id=5467][/sociallocker]

Ensuite, je veux comparer le résultat de ce traitement (en E2) avec une la feuille initiale.

Choisir une feuille de comparaison en changeant le contenu d’une cellule – fonction INDIRECT

=SI(A5=INDIRECT($B$1&”!A”&LIGNE());”IDENTIQUE PAR RAPORT A LA REF DE COMPARAISON”;”ECART”)

Ci-dessous, le détail de la formule.

En Feuille Initiale, on a ceci :

EXCEL_2007_ANALYSE_ECART_ONGLET

EXCEL_2007_ANALYSE_ECART_ONGLET

Et on veut comparer cette feuille initiale avec la version 1 sur l’onglet V1 et la version 2 sur l’onglet V2 (Changement d’indice)

 

Version Youtube :

EXCEL_2007_ANALYSE_ECART_ONGLET

D’où la formule suivante :

EXCEL_2007_ANALYSE_ECART_ONGLET

EXCEL_2007_ANALYSE_ECART_ONGLET

Vous pouvez vérifier la formule avec : l’évaluation de formule

EXCEL_2007_ANALYSE_ECART_ONGLET

EXCEL_2007_ANALYSE_ECART_ONGLET

D’où la formule suivante :
=SI(A5=INDIRECT($B$1&”!A”&LIGNE());”IDENTIQUE PAR RAPPORT A LA REF DE COMPARAISON”;”ECART”)
qui permet de reprendre l’adresse de la cellule à comparer :
$B$1&”!A”&LIGNE()
soit
“Liste B”=INDIRECT($B$1&”!A”&LIGNE());”IDENTIQUE PAR RAPPORT A LA REF DE COMPARAISON”;”ECART”)
et ensuite avec INDIRECT de renvoyer la valeur de la cellule.

On se trouve donc avec une formule comme ceci :
=SI(“Liste B”=INDIRECT(“V1&!A”&LIGNE());”IDENTIQUE PAR RAPPORT A LA REF DE COMPARAISON”;”ECART”), soit après plusieurs clic ” Evaluer” sur l’évaluation de formule.

=SI(“Liste B”=INDIRECT(“V1!A5”);”IDENTIQUE PAR RAPPORT A LA REF DE COMPARAISON”;”ECART”), soit)

et le INDIRECT renvoit donc :
=SI(“Liste B”=“Liste B”;”IDENTIQUE PAR RAPPORT A LA REF DE COMPARAISON”;”ECART”)

Evidemment, deux avantages :
-- on peut recopier la formule vers le bas, grâce à LIGNE.
-- en changeant la valeur en B1 (Choix de l’onglet à comparer), par exemple, en utilisant un menu déroulant, vous changez la référence de comparaison.

Recevoir la newsletter

Inscrivez-vous maintenant et recevez un e-mail les fois où je publie du contenu.

I agree to have my personal information transfered to AWeber ( more information )

Je hais les spams. Vous pouvez vous désinscrire à tout moment.

Pour marque-pages : Permaliens.

Laisser un commentaire